package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(тр[ау]м-?)*`)
var str = `трам-трам-трумтрам-трум-трам`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}