package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`a|e|i|o|u`)
var str = `plaster`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}