re = /(?<!:\/\/)([a-zA-Z0-9-_]+\.)*[a-zA-Z0-9][a-zA-Z0-9-_]+\.[a-zA-Z]{2,11}/mx
str = 'banana google.com juice
google.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end