$re = '/(?<=[/])ft\-file(?=[\/])/m';
$str = '[test="data/ft-file/images/small/red"]
[test="data/ft-file2/images/small/red"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);