package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([A-Z]+|[a-z]+)`)
var str = `HOWtoDOthis`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}