package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[ |])([A-Z]+<\d+:\d)>`)
var str = `[impro:0,grp:00,time:0xac,magic:0x00ac] CAR<7:5>|BIKE<4:0>,orig:0x8c,new:0x97
[impro:0,grp:00,time:0xbc,magic:0x00bc] CAKE<4:0>,orig:0x0d,new:0x17`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}