import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:musicdb|videodb|special):\\/\\/(?<Type>albums|tvshows|genres|masterprofile|artists)\\/(?:titles\\/)?(?<Identifier>[\\w\\d\\-.]+)\\/?(?<Season>\\d+)?";
final String string = "musicdb://albums/2/\n"
+ "videodb://tvshows/titles/1/\n"
+ "videodb://tvshows/titles/1/5/?tvshowid=1\n"
+ "musicdb://genres/2/\n"
+ "special://masterprofile/PartyMode-Video.xsp\n"
+ "musicdb://artists/2/?albumartistonly=false";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}