#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z]+\d*\b"
Local $sString = "Buveinės adresas: Konstitucijos pr. 20A, 03502 Vilnius" & @CRLF & _
"Telefonai:" & @CRLF & _
"1884 arba +370 5 268 4444 (Privatiems klientams)" & @CRLF & _
"1633 arba +370 5 268 4422 (Verslo klientams)" & @CRLF & _
"Faksas: (8 5) 258 2700" & @CRLF & _
"El. paštas: info@swedbank.lt" & @CRLF & _
"Įmonės kodas: 112029651" & @CRLF & _
"PVM mokėtojo kodas: LT120296515" & @CRLF & _
"Banko sąskaita: LT55 7300 0100 0000 0036" & @CRLF & _
"Banko kodas: 73000" & @CRLF & _
"SWIFT kodas: HABALT22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")