$re = '/\[([^]^[0-9]]+)\]/';
$str = '8:30 [Cooking 8:30-10:30]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);