re = /\A(?=.*[A-Z].*[A-Z])(?=.*[a-z].*[a-z])(?=.*[0-9].*[0-9])(?=.*[^a-zA-Z0-9].*[^a-zA-Z0-9])/i
str = '!wA2As#3'
# Print the match result
str.match(re) do |match|
puts match.to_s
end