import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w.*(_|-).*(\\d{2})|(\\d{3}))((_|-)(\\d{3})|(\\d{4})_)(.*)(\\..*)";
final String string = "M-115_032_St_svetliy.jpg\n"
+ "M-109_064_Zeleniy_RAL_6018_matoviy.jpg\n"
+ "M-109_064_St_svetliy.jpg\n"
+ "RL_07_15_00_096_1024_beliy_RAL_9010_matoviy_beliy_RAL_9010_matoviy.jpg\n"
+ "RL_07_15_00_096_1024_cherniy_RAL_9005_glyanceviy_cherniy_RAL_9005_glyanceviy.jpg\n"
+ "RL_07_15_00_096_1024_Cr_glyanceviy_St_svetliy.jpg\n"
+ "RL_07_15_00_096_1024_St_svetliy_St_svetliy.jpg\n"
+ "FS-043_192_Cr_matoviy.jpg\n"
+ "FS-043_160_Cr_matoviy.jpg\n"
+ "FS-043_192_Cr_glyanceviy.jpg\n"
+ "S-155_096_Ni_nikel.jpg\n"
+ "S-165_128_Ni_nikel.jpg\n"
+ "FS-135_096_olovo_shlifovannoe.jpg\n"
+ "FS-128_128_olovo_shlifovannoe.jpg\n"
+ "FB-025_000_olovo_shlifovannoe.jpg\n"
+ "FB-025_000_bronza_polirovannaya.jpg\n"
+ "FS-162_128_Cr_matoviy_kristalli.jpg\n"
+ "FK-011_010_med_shlifovannaya.jpg\n"
+ "FK-011_020_med_shlifovannaya.jpg\n"
+ "FM-078_032_Cr_glyanceviy_emal_T212801_smoke.jpg\n"
+ "FB-031_000_staroe_olovo_kristall.jpg\n"
+ "FB-031_000_staraya_bronza_kristall.jpg\n"
+ "FB-031_000_bronza_polirovannaya_kristall.jpg\n"
+ "S-165_128_St_svetliy.jpg\n"
+ "FS-140_096_staroe_olovo.jpg\n"
+ "FS-140_064_staroe_olovo.jpg\n"
+ "FS-140_128_staroe_olovo.jpg\n"
+ "FS-128_096_olovo_shlifovannoe.jpg\n"
+ "FM-086_032_staroe_olovo.jpg\n"
+ "FM-086_032_olovo_shlifovannoe.jpg\n"
+ "FM-071_032_staroe_olovo.jpg\n"
+ "FM-105_000_staroe_olovo.jpg\n"
+ "FM-102_000_staroe_olovo.jpg\n"
+ "FS-129_128_staroe_olovo.jpg\n"
+ "FM-088_064_olovo_shlifovannoe.jpg\n"
+ "FS-129_128_olovo_shlifovannoe.jpg\n"
+ "FS-160_096_staroe_olovo.jpg\n"
+ "FM-094_032_staroe_olovo_beliy.jpg\n"
+ "FB-033_000_staroe_olovo_beliy.jpg\n"
+ "FS-141_096B_staroe_olovo_beliy.jpg\n"
+ "FB-026_000_staroe_olovo_beliy.jpg\n"
+ "PM(12)_00_00_096_1024_St_svetliy.jpg\n"
+ "PM(13)_00_00_096_1024_St_svetliy.jpg\n"
+ "RL(05)_18_00_128_1024_St_svetliy_Cr_glyanceviy_kromka-vishnya_mat.jpg\n"
+ "FM-088_064_Cr_glyanceviy.jpg\n"
+ "FM-088_064_bronza_shlifovannaya.jpg\n"
+ "FM-088_064_med_shlifovannaya.jpg\n"
+ "FM-088_064_staraya_med.jpg\n"
+ "FM-088_064_staraya_bronza.jpg\n"
+ "FM-088_064_Zoloto.jpg\n"
+ "FB-025_000_staraya_bronza.jpg\n"
+ "FM-088_064_bronza_polirovannaya.jpg\n"
+ "FS-129_128_bronza_polirovannaya.jpg\n"
+ "FM-064_000_Cr_glyanceviy_emal_farfor_9001.jpg\n"
+ "FM-064_032_Cr_glyanceviy_emal_farfor_9001.jpg\n"
+ "FB-029_000_staroe_olovo_kristal.jpg\n"
+ "FB-030_000_staroe_olovo_kristall.jpg\n"
+ "FS-143_128_staroe_olovo_kristall.jpg\n"
+ "FS-125_064_staroe_olovo_kristal.jpg\n"
+ "FS-125_128_staroe_olovo_kristal.jpg\n"
+ "FB-018_000_staroe_olovo_kristall.jpg\n"
+ "FS-134_096_staroe_olovo.jpg\n"
+ "FS-134_064_staroe_olovo.jpg\n"
+ "FS-139_128_staroe_olovo_beliy.jpg\n"
+ "FS-138_128_staroe_olovo_beliy.jpg\n"
+ "FB-027_000_staroe_olovo_beliy.jpg\n"
+ "FS-141_096_staroe_olovo.jpg\n"
+ "M-108_128_St_svetliy_kromka_venge_matoviy.jpg\n"
+ "FS-159_096_bronza_kristalli.jpg\n"
+ "FS-159_096_Cr_glyanceviy_kristalli.jpg\n"
+ "FS-161_160_Ni_zhemchuzhniy.jpg\n"
+ "FS-161_160_Cr_matoviy.jpg\n"
+ "FS-161_160_metallik_zolotistiy.jpg\n"
+ "FS-163_160_metallik_zolotistiy.jpg\n"
+ "FS-163_160_Cr_matoviy.jpg\n"
+ "FS-163_160_zoloto.jpg\n"
+ "FS-163_160_Cr_glyanceviy.jpg\n"
+ "FK-015_020_St_svetliy_venge_matoviy.jpg\n"
+ "FK-015_010_St_svetliy_venge_matoviy.jpg\n"
+ "FS-160_096_med_shlifovannaya.jpg\n"
+ "FS-160_096_bronza_shlifovannaya.jpg\n"
+ "FS-160_096_staraya_bronza.jpg\n"
+ "FS-160_096_Zoloto.jpg\n"
+ "FS-160_096_Cr_glyanceviy.jpg\n"
+ "FM-105_000_Cr_glyanceviy.jpg\n"
+ "FM-105_000_Cr_Zoloto.jpg\n"
+ "FM-105_000_med_shlifovannaya.jpg\n"
+ "FM-105_000_staraya_bronza.jpg\n"
+ "FM-102_000_Cr_staraya_bronza.jpg\n"
+ "FM-102_000_staraya_med.jpg\n"
+ "FM-102_000_bronza_shlifovannaya.jpg\n"
+ "S-101_128_St_svetliy_kromka_venge_matoviy.jpg\n"
+ "S-101_128_St_svetliy_kromka_buk_matoviy.jpg\n"
+ "S-101_128_St_svetliy_kromka_bvishnya_matovaya.jpg\n"
+ "RL(06)_18_00_128_1024_St_svetliy_Cr_glyanceviy.jpg\n"
+ "RL(05)_10_00_096_1024_St_svetliy_St_svetliy_kromka-vishnya_mat.jpg\n"
+ "FS-161_160_Cr_glyanceviy.jpg\n"
+ "FS-159_128_med_shlifovannaya_kristalli.jpg\n"
+ "FS-159_128_Zoloto_kristalli.jpg\n"
+ "FS-159_128_bronza_polirovannaya_kristalli.jpg\n"
+ "FS-159_128_Cr_matoviy_kristalli.jpg\n"
+ "FS-159_128_Cr_glyanceviy_kristalli.jpg\n"
+ "FS-158_128_staraya_bronza_beliy.jpg\n"
+ "FS-158_128_stal_shlifovannaya_beliy.jpg\n"
+ "FS-158_128_Zoloto_beliy.jpg\n"
+ "FS-158_128_bronza_shlifovannaya_beliy.jpg\n"
+ "FS-158_128_bronza polirovannaya_beliy.jpg\n"
+ "FS-158_128_Ni_zhemchuzhniy_beliy.jpg\n"
+ "FS-112_128_Cr_glyanceviy_kristalli.jpg\n"
+ "FR-009_096_1024_St_svetliy_Cr_glyanceviy.jpg\n"
+ "FB-039_000_staraya_bronza_beliy.jpg\n"
+ "FB-039_000_med_shlifovannaya_beliy.jpg\n"
+ "FB-039_000_Zoloto_beliy.jpg\n"
+ "FB-039_000_bronza_polirovannaya_beliy.jpg\n"
+ "FB-039_000_Cr_glyanceviy_beliy.jpg\n"
+ "FM-102_000_bronza_polirovannaya.jpg\n"
+ "FM-102_000_Zoloto.jpg\n"
+ "FM-062_032_Cr_glyanceviy.jpg\n"
+ "FM-062_032_Cr_glyanceviy_kristalli.jpg\n"
+ "FM-063_064_Cr_glyanceviy_kristalli.jpg\n"
+ "FM-080_064_Cr_glyanceviy_emal_fuksiya_210.jpg\n"
+ "FM-094_096_bronza_polirovannaya_beliy.jpg\n"
+ "FM-104_000_Cr_glyanceviy_kristalli.jpg\n"
+ "FM-104_000_Cr_matoviy_kristalli.jpg\n"
+ "FM-104_000_Ni_zhemchuzhniy_kristalli.jpg\n"
+ "FM-104_000_bronza_polirovannaya_kristalli.jpg\n"
+ "FM-104_000_Zoloto_kristalli.jpg\n"
+ "FM-104_000_med_shlifovannaya_kristalli.jpg\n"
+ "FM-104_000_staraya_bronza_kristalli.jpg\n"
+ "FM-104_000_staraya_med_kristalli.jpg\n"
+ "FM-104_032_Cr_glyanceviy_kristalli.jpg\n"
+ "FM-104_032_Cr_matoviy_kristalli.jpg\n"
+ "FM-104_032_Ni_zhemchuzhniy_kristalli.jpg\n"
+ "FM-104_032_bronza_polirovannaya_kristalli.jpg\n"
+ "FM-104_032_bronza_shlifovannaya_kristalli.jpg\n"
+ "FM-104_032_Zoloto_kristalli.jpg\n"
+ "FM-104_032_med_shlifovannaya_kristalli.jpg\n"
+ "FM-104_032_staraya_bronza_kristalli.jpg\n"
+ "FM-104_032_staraya_med_kristalli.jpg\n"
+ "FM-102_000_Cr_matoviy.jpg\n"
+ "FS-158_128_Cr_glyanceviy_beliy.jpg\n"
+ "FS-158_128_Cr_matoviy_beliy.jpg\n"
+ "FS-158_128_med_shlifovannaya_beliy.jpg\n"
+ "FM-102_000_Cr_glyanceviy.jpg\n"
+ "S-155_096_St_svetliy.jpg\n"
+ "FM-086_032_Zoloto_emal_farfor_9001.jpg\n"
+ "FM-086_032_Cr_glyanceviy_emal_farfor_9001.jpg\n"
+ "FM-086_032_Cr_glyanceviy.jpg\n"
+ "FB-029_000_Zoloto_kristal.jpg\n"
+ "FB-029_000_Cr_glyanceviy_kristal.jpg\n"
+ "FM-092_032_Ni_zhemchuzhniy_beliy.jpg\n"
+ "FM-092_032_staraya_med_beliy.jpg\n"
+ "FM-092_032_med_shlifovannaya_beliy.jpg\n"
+ "FM-092_032_Zoloto_beliy.jpg\n"
+ "FM-092_032_Cr_glyanceviy_beliy.jpg\n"
+ "FM-092_032_Cr_matoviy_beliy.jpg\n"
+ "FM-092_032_bronza_polirovannaya_beliy.jpg\n"
+ "S-156_096_St_svetliy_kromka-venge_matoviy.jpg\n"
+ "FM-094_032_staraya_med_beliy.jpg\n"
+ "FM-094_032_Cr_matoviy_beliy.jpg\n"
+ "FM-094_032_bronza_shlifovannaya_beliy.jpg\n"
+ "FM-094_032_staraya_bronza_beliy.jpg\n"
+ "FM-094_032_Cr_glyanceviy_,beliy.jpg\n"
+ "FM-094_032_Ni_zhemchuzhniy_beliy.jpg\n"
+ "FM-094_032_med_shlifovannaya_beliy.jpg\n"
+ "FM-071_032_Zoloto_emal_chernaya_395.jpg\n"
+ "FM-071_032_Zoloto_emal_farfor_9001.jpg\n"
+ "FM-071_032_Zoloto.jpg\n"
+ "FM-083_032_zhemchuzhniy_Ni.jpg\n"
+ "FM-083_032_hrom_matoviy.jpg\n"
+ "FM-083_032_stal_shlifovannaya.jpg\n"
+ "FM-083_032_bronza_polirovannaya.jpg\n"
+ "FM-083_032_Zoloto.jpg\n"
+ "FM-071_032_staraya_med.jpg\n"
+ "FM-071_032_bronza_shlifovannaya.jpg\n"
+ "FM-071_032_bronza_polirovannaya.jpg\n"
+ "FM-071_032_Cr_glyanceviy.jpg\n"
+ "FM-081_000_stal_shlifovannaya.jpg\n"
+ "FM-081_000_zhemchuzhniy_Ni.jpg\n"
+ "FM-081_000_med_shlifovannaya.jpg\n"
+ "FM-081_000_staraya_med.jpg\n"
+ "FM-081_000_Zoloto_emal_farfor_9001.jpg\n"
+ "FM-081_000_Cr_matoviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg\n"
+ "FM-081_000_Cr_matoviy_emal_farfor_9001.jpg\n"
+ "FM-081_000_Cr_matoviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FM-081_000_Cr_matoviy.jpg\n"
+ "FM-081_000_Cr_glyanceviy_emal_posloynaya_farfor 9001_bescvetnaya_801.jpg\n"
+ "FM-081_000_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FM-081_000_Cr_glyanceviy.jpg\n"
+ "FM-081_000_bronza_shlifovannaya.jpg\n"
+ "FM-081_000_bronza_polirovannaya.jpg\n"
+ "FM-081_000_staraya_bronza.jpg\n"
+ "FM-081_032_med_shlifovannaya.jpg\n"
+ "FS-124_096_staraya_med.jpg\n"
+ "FS-124_096_Zoloto_emal_farfor_9001.jpg\n"
+ "FS-124_096_Cr_matoviy.jpg\n"
+ "FS-124_096_Cr_matoviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FS-124_096_Cr_matoviy_emal_posloynaya_farfor_9001.jpg\n"
+ "FS-124_096_Cr_glyanceviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg\n"
+ "FS-124_096_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FS-124_096_Cr_glyanceviy.jpg\n"
+ "FS-124_096_bronza_polirovannaya.jpg\n"
+ "FM-081_032_staraya_med.jpg\n"
+ "FM-081_032_Zoloto_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg\n"
+ "FM-081_032_Zoloto.jpg\n"
+ "FM-081_032_Cr_matoviy_emal_farfor_9001.jpg\n"
+ "FM-081_032_Cr_matoviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg\n"
+ "FM-081_032_Cr_matoviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FM-081_032_Cr_matoviy.jpg\n"
+ "FM-081_032_Cr_glyanceviy_emal_posloynaya_farfor_9001_bescvetnaya_801.jpg\n"
+ "FM-081_032_Cr_glyanceviy_emal_chernaya_395.jpg\n"
+ "FM-081_032_Cr_glyanceviy.jpg\n"
+ "FM-081_032_bronza_shlifovannaya.jpg\n"
+ "FM-081_032_bronza_polirovannaya.jpg\n"
+ "FS-132_064_Zoloto.jpg\n"
+ "FS-132_064_med_shlifovannaya.jpg\n"
+ "FS-132_064_zhemchuzhniy_Ni.jpg\n"
+ "FS-132_064_staraya_med.jpg\n"
+ "FS-132_064_staraya_bronza.jpg\n"
+ "FS-132_064_bronza_shlifovannaya.jpg\n"
+ "FS-132_064_Cr_matoviy.jpg\n"
+ "FS-132_064_Cr_glyanceviy.jpg\n"
+ "FS-135_064_Cr_glyanceviy.jpg\n"
+ "FS-135_064_Zoloto.jpg\n"
+ "FS-135_064_staraya_med.jpg\n"
+ "FS-135_064_bronza_shlifovannaya.jpg\n"
+ "FD-028_000_Ni_zhemchuzhniy.jpg\n"
+ "FD-028_000_shlifovannaya_med.jpg\n"
+ "FD-028_000_staraya_med.jpg\n"
+ "FD-028_000_Zoloto.jpg\n"
+ "FD-028_000_Cr_matoviy.jpg\n"
+ "FD-028_000_Cr_glyanceviy.jpg\n"
+ "FD-028_000_bronza_shlifovannaya.jpg\n"
+ "FD-028_000_bronza_polirovannaya.jpg\n"
+ "FD-030_000_Ni_zhemchuzhniy.jpg\n"
+ "FD-030_000_Cr_matoviy.jpg\n"
+ "FD-030_000_Cr_glyanceviy.jpg\n"
+ "FD-030_000_bronza_shlifovannaya.jpg\n"
+ "FD-030_000_bronza_polirovannaya.jpg\n"
+ "FD-030_000_staraya_bronza.jpg\n"
+ "FD-030_000_Zoloto.jpg\n"
+ "FB-030_000_Zoloto_kristall.jpg\n"
+ "FB-031_000_Zoloto_kristall.jpg\n"
+ "FS-138_128_Zoloto_beliy.jpg\n"
+ "FS-140_128_Cr_glyanceviy.jpg\n"
+ "FS-140_128_Zoloto.jpg\n"
+ "FS-140_096_Zoloto.jpg\n"
+ "FS-140_096_bronza_polirovannaya.jpg\n"
+ "FS-140_064_Zoloto.jpg\n"
+ "FS-140_064_Cr_glyanceviy.jpg\n"
+ "FS-140_064_bronza_polirovannaya.jpg\n"
+ "FS-135_096_Zoloto.jpg\n"
+ "FS-135_096_Cr_glyanceviy.jpg\n"
+ "FS-111_128_zhemchuzhniy_Ni.jpg\n"
+ "FS-111_128_Cr_glyanceviy.jpg\n"
+ "FS-122_128_staraya_bronza_emal_farfor_9001.jpg\n"
+ "FS-122_128_Cr_glyanceviy_emal_farfor_9001_emal_aliy_363.jpg\n"
+ "FM-078_032_staraya_bronza_emal_farfor_9001.jpg\n"
+ "FM-078_032_Cr_glyanceviy_emal_farfor_9001_emal_krasnaya_3063.jpg\n"
+ "FS-121_128_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FM-077_000_staraya_bronza.jpg\n"
+ "FM-077_000_Cr_glyanceviy_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FM-071_032_Cr_glyanceviy_emal_posloynaya_slonovaya_kost_9002_bescvetnaya_801.jpg\n"
+ "FM-071_032_Zoloto_emal_posloynaya_chernaya_395_bescvetnaya_801.jpg\n"
+ "FM-094_032_Zoloto_beliy.jpg\n"
+ "FS-141_096_bronza_polirovannaya.jpg\n"
+ "FS-141_096_Zoloto.jpg\n"
+ "FS-141_096B_Zoloto_beliy.jpg\n"
+ "FS-141_096B_bronza_polirovannaya_beliy.jpg\n"
+ "FB-033_000_Zoloto_beliy.jpg\n"
+ "FS-142_096_zhemchuzhniy_Ni_kristall.jpg\n"
+ "FS-142_096_Zoloto_kristall.jpg\n"
+ "FS-143_128_Zoloto_kristall.jpg\n"
+ "FB-027_000_Zoloto_beliy.jpg\n"
+ "FS-139_128_Zoloto_beliy.jpg\n"
+ "FS-135_064_staraya_bronza.jpg\n"
+ "FB-028_064_staraya_bronza.jpg\n"
+ "FS-131_128_Cr_glyanceviy.jpg\n"
+ "FS-131_128_staraya_bronza.jpg\n"
+ "FS-135_096_staraya_bronza.jpg\n"
+ "FS-111_128_staraya_bronza.jpg\n"
+ "FS-122_128_Zoloto_emal_bruno_T475.jpg\n"
+ "FS-122_128_Cr_glyanceviy_emal_fuksiya_210.jpg\n"
+ "FM-078_032_Zoloto_emal_bruno_T475.jpg\n"
+ "FM-077_000_Cr_glyanceviy_emal_chernaya_395.jpg\n"
+ "FM-077_000_Zoloto_emal_chernaya_395.jpg\n"
+ "FS-121_128_Zoloto_emal_chernaya 395.jpg\n"
+ "FS-121_128_Cr_glyanceviy_emal_chernaya 395.jpg\n"
+ "FS-121_128_staraya_bronza.jpg\n"
+ "FB-033_000_bronza_polirovannaya_beliy.jpg\n"
+ "FM-094_032_bronza_polirovannaya_beliy.jpg\n"
+ "FS-141_096B_staraya_bronza_beliy.jpg\n"
+ "FS-141_096_staraya_bronza.jpg\n"
+ "FS-043_192_Cr_glyanceviy_emal_395_chernaya.jpg\n"
+ "FS-043_128_Cr_glyanceviy_emal_395_chernaya.jpg\n"
+ "FS-043_160_Cr_glyanceviy_emal_395_chernaya.jpg\n"
+ "FB-018_000_Zoloto_kristall.jpg\n"
+ "FS-142_096_Cr_glyanceviy_kristall.jpg\n"
+ "FB-031_000_Cr_glyanceviy_kristall.jpg\n"
+ "FB-031_000_zhemchuzhniy_Ni_kristall.jpg\n"
+ "FS-142_096_bronza polirovannaya_kristall.jpg\n"
+ "FS-131_128_bronza_shlifovannaya.jpg\n"
+ "FS-157_096_bronza_shlifovannaya.jpg\n"
+ "FS-157_096_bronza_polirovannaya.jpg\n"
+ "FS-144_096_Cr glyanceviy.jpg\n"
+ "FS-144_096_Zoloto.jpg\n"
+ "FS-144_096_staraya_bronza.jpg\n"
+ "FS-144_096_staraya_med.jpg\n"
+ "FS-144_096_med_shlifovannaya.jpg\n"
+ "FS-144_096_bronza_shlifovannaya.jpg\n"
+ "FS-152_096_bronza_shlifovannaya.jpg\n"
+ "FB-036_000_staraya_bronza.jpg\n"
+ "FB-036_000_bronza_polirovannaya.jpg\n"
+ "FS-154_096_bronza_shlifovannaya.jpg\n"
+ "FS-154_096_bronza_polirovannaya.jpg\n"
+ "FS-154_096_Cr_matoviy.jpg\n"
+ "FS-154_096_Cr_glyanceviy.jpg\n"
+ "FB-036_000_Cr_glyanceviy.jpg\n"
+ "FB-036_000_med_shlifovannaya.jpg\n"
+ "FS-152_096_med_shlifovannaya.jpg\n"
+ "FS-152_096_bronza polirovannaya.jpg\n"
+ "FS-152_096_staraya_med.jpg\n"
+ "FB-035_000_staraya med.jpg\n"
+ "FB-035_000_Zoloto.jpg\n"
+ "FB-035_000_Cr_glyanceviy.jpg\n"
+ "FB-035_000_bronza_polirovannaya.jpg\n"
+ "FB-037_000_med_shlifovannaya.jpg\n"
+ "FB-037_000_Cr_glyanceviy.jpg\n"
+ "FM-086_032_Zoloto_emal_bruno_T475.jpg\n"
+ "FS-128_096_Zoloto_emal_bruno_T475.jpg\n"
+ "FB-019_000_Zoloto_emal_bruno_T475.jpg\n"
+ "FS-115_096_med_shlifovannaya_beliy_kristall.jpg\n"
+ "FS-115_096_staraya_bronza_beliy_kristall.jpg\n"
+ "FS-115_096_Cr_matoviy_beliy_kristall.jpg\n"
+ "FS-115_096_Zoloto_beliy_kristall.jpg\n"
+ "FN-001_000_staraya_med.jpg\n"
+ "FN-004_000_staraya_bronza.jpg\n"
+ "FN-002_000_staraya_bronza.jpg\n"
+ "FN-003_000_staraya_bronza.jpg\n"
+ "FS-143_128_Cr_glyanceviy_kristall.jpg\n"
+ "FB-030_000_Cr_glyanceviy_kristall.jpg\n"
+ "FS-138_128_bronza_polirovannaya_beliy.jpg\n"
+ "FS-138_128_Cr_glyanceviy_beliy.jpg\n"
+ "FB-027_000_Cr_glyanceviy_beliy.jpg\n"
+ "FB-027_000_bronza_polirovannaya_beliy.jpg\n"
+ "FS-128_128_Zoloto_emal_bruno_T475.jpg\n"
+ "FS-123_128_Zoloto_emal_bruno_T475.jpg\n"
+ "FM-087_032_Zoloto_emal_bruno_T475.jpg\n"
+ "FS-139_128_bronza_polirovannaya_beliy.jpg\n"
+ "FS-139_128_Cr_glyanceviy_beliy.jpg\n"
+ "FB-026_000_Cr_glyanceviy_beliy.jpg\n"
+ "FB-026_000_bronza_polirovannaya_beliy.jpg\n"
+ "FB-026_000_Zoloto_beliy.jpg\n"
+ "S-153_096_St_svetliy_kromka-vishnya_matovaya.jpg\n"
+ "S-150_128_St_svetliy_kromka-vishnya_matovaya.jpg\n"
+ "S-149_128_St_svetliy_kromka-buk_matoviy.jpg\n"
+ "S-146_128_St_svetliy_kromka-buk_matoviy.jpg\n"
+ "S-148_128_St_svetliy_kromka-venge_matoviy.jpg\n"
+ "S-148_096_St_svetliy_kromka-venge_matoviy.jpg\n"
+ "B-034_000_St_svetliy_kromka-venge_matoviy.jpg\n"
+ "S-145_128_St_svetliy_kromka-venge_matoviy.jpg\n"
+ "FS-128_128_bronza_polirovannaya.jpg\n"
+ "FS-128_096_bronza_polirovannaya.jpg\n"
+ "FS-125_160_Cr_glyanceviy_kristalli.jpg\n"
+ "FS-125_160_bronza_polirovannaya_kristalli.jpg\n"
+ "FS-125_160_Zoloto_kristall.jpg\n"
+ "FS-125_128_Zoloto_kristalli.jpg\n"
+ "FS-125_128_Cr_glyanceviy_kristalli.jpg\n"
+ "FS-125_128_polirovannaya_bronza_kristalli.jpg\n"
+ "FS-123_128_bronza_polirovannaya.jpg\n"
+ "FS-115_096_zhemchuzhniy_Ni_beliy_kristall.jpg\n"
+ "FS-115_096_staraya med_beliy_kristall.jpg\n"
+ "FS-115_096_Cr_glyanceviy_beliy_kristall.jpg\n"
+ "FM-087_032_bronza_polirovannaya.jpg\n"
+ "FM-086_032_bronza_polirovannaya.jpg\n"
+ "FS-126_160_Cr_glyanceviy.jpg\n"
+ "FM-083_032_Cr_glyanceviy.jpg\n"
+ "FD-031_000_bronza polirovannaya_belie kristalli.jpg\n"
+ "FB-019_000_bronza_polirovannaya.jpg\n"
+ "FB-018_000_bronza_polirovannaya_kristall.jpg\n"
+ "FB-018_000_Cr_glyanceviy_kristall.jpg\n"
+ "FD-031_000_Cr_glyanceviy_belie kristalli.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}