#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?:[^_]*_){5}[^_]*\K(.*)\b"
Local $sString = "HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.html" & @CRLF & _
"HTZ_2015_CS_SS5_cncenter_1020x200_AS2_10K.swf" & @CRLF & _
"HTZ_2015_CS_SS5_cncenter_1500x1000_160K_w1020.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")