$re = '/(?!\/)[^\/]+(?=_)/m';
$str = 'c://abcd /abcdef/0012wetr_1234567890.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);