package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^>]+>`)
var str = `<html>
<head>
<title>Hello World</title>
</head>
<body>
The whole world is facing economic challenge due to Coronavirus pandemic.
</body>
</html>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}