$re = '/^(\d*[.,]?\d*)*$/m';
$str = '9.8
54
9,8
3.21.13.1.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);