const regex = /[!#\$%&\'\*\+\-\/0-9=\?a-z\^_`\{\}\|~]*(?:\\[\x00-\x7F][!#\$%&\'\*\+\-\/0-9=\?a-z\^_`\{\}\|~]*)*(?:\.[!#\$%&\'\*\+\-\/0-9=\?a-z\^_`\{\}\|~]*(?:\\[\x00-\x7F][!#\$%&\'\*\+\-\/0-9=\?a-z\^_`\{\}\|~]*)*)*@[a-z0-9](?:[a-z0-9-]*[a-z0-9])?(?:\.[a-z0-9](?:[a-z0-9-]*[a-z0-9])?)*\.[a-z]{2,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[!#\\$%&\\\'\\*\\+\\-\\\/0-9=\\?a-z\\^_`\\{\\}\\|~]*(?:\\\\[\\x00-\\x7F][!#\\$%&\\\'\\*\\+\\-\\\/0-9=\\?a-z\\^_`\\{\\}\\|~]*)*(?:\\.[!#\\$%&\\\'\\*\\+\\-\\\/0-9=\\?a-z\\^_`\\{\\}\\|~]*(?:\\\\[\\x00-\\x7F][!#\\$%&\\\'\\*\\+\\-\\\/0-9=\\?a-z\\^_`\\{\\}\\|~]*)*)*@[a-z0-9](?:[a-z0-9-]*[a-z0-9])?(?:\\.[a-z0-9](?:[a-z0-9-]*[a-z0-9])?)*\\.[a-z]{2,}', '')
const str = `post@formateins.de
adrian.balboa@mail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}