package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*?\.GsonAdapters.*`)
var str = `com.tools.vo.event.GsonAdaptersGetEventDataBalancesVO`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}