import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9.]";
final String string = "a\n"
+ "test\n"
+ ".\n"
+ "cow\n"
+ "!\n"
+ "@\n"
+ "#\n"
+ "@\n"
+ "\\\n"
+ "]\n"
+ "[\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}