$re = '/{{([^}}]+)}}\[\[[^\]\]]+\]\](?=[^[]*]\s*\()/';
$str = 'Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc rhoncus arcu sed libero pulvinar venenatis. Curabitur fermentum aliquam metus. Mauris tempor cursus blandit. Integer at diam semper, imperdiet leo at, egestas elit. Proin pellentesque, turpis et laoreet blandit, ligula nisl dictum massa, ut finibus nunc magna sed ex. Pellentesque nec suscipit lectus. Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere cubilia Curae; In dictum lacus eget nibh laoreet condimentum. {{Vitae}}[[1234]] laoreet augue. Sed nulla nunc, suscipit nec lectus {{vitae}}[[1234]], vestibulum iaculis nisl. Nulla leo ligula, euismod ac vehicula sed, hendrerit ac risus. Quisque non mauris a magna interdum bibendum tempor et magna. Cras tempus convallis tellus, non elementum diam lobortis eu.
![**Placeholder 1.** Ut a eleifend est. Suspendisse pharetra id lacus nec sodales. In blandit erat justo, quis eleifend sapien rutrum vel. Fusce et diam ligula. Donec lectus elit, convallis eu lectus faucibus, volutpat vulputate nulla. Morbi {{vitae}}[[1234]] lacinia sapien. Nunc id nisi et lorem pharetra eleifend sed a nunc. Suspendisse vulputate felis dui, eget egestas leo malesuada a. {{Vitae}}[[1234]] accumsan lorem. Curabitur nec dolor finibus, iaculis odio porttitor, condimentum ante. Duis et tellus augue. Proin hendrerit magna at aliquam venenatis. Nulla ut magna aliquet, sollicitudin risus vel, rhoncus orci. Etiam erat est, suscipit non mattis interdum, rutrum eu ipsum. Ut sodales lobortis diam. Quisque vestibulum neque at lectus sollicitudin consectetur](http://placehold.it/350x150)
![**Placeholder 2.** Ut a eleifend est. Suspendisse pharetra id lacus nec sodales. In blandit erat justo, quis eleifend sapien rutrum vel. Fusce et diam ligula. Donec lectus elit, convallis eu lectus faucibus, volutpat vulputate nulla. Morbi {{vitae}}[[1234]] lacinia sapien. Nunc id nisi et lorem pharetra eleifend sed a nunc. Suspendisse vulputate felis dui, eget egestas leo malesuada a. {{Vitae}}[[1234]] accumsan lorem. Curabitur nec dolor finibus, iaculis odio porttitor, condimentum ante. Duis et tellus augue. Proin hendrerit magna at aliquam venenatis. Nulla ut magna aliquet, sollicitudin risus vel, rhoncus orci. Etiam erat est, suscipit non mattis interdum, rutrum eu ipsum. Ut sodales lobortis diam. Quisque vestibulum neque at lectus sollicitudin consectetur](http://placehold.it/350x150)
Vestibulum ante dui, dapibus sed est tincidunt, bibendum mattis ex. Vivamus blandit mauris arcu, ornare pretium eros pretium sed. Donec molestie augue auctor, sollicitudin massa vel, tristique nisl. Donec nulla leo, vehicula sit amet sagittis non, dictum eget mi. Morbi suscipit id justo vel rutrum. Nullam lacus eros, consequat {{vitae}}[[1234]] orci a, ultrices aliquam enim. Nam finibus varius mattis. Nunc consequat ex eu nisi dapibus sagittis. Donec dictum est eu sapien viverra sollicitudin. Duis ut tempor metus. Nullam aliquam dui sit amet nibh dignissim bibendum. Duis et metus imperdiet, suscipit dolor in, vestibulum metus. Nullam egestas nulla a mi lobortis venenatis. Sed facilisis erat elit, nec ullamcorper ligula condimentum {{vitae}}[[1234]]. Nunc mollis nisi quis tortor consectetur sagittis.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);