#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\[ [^\]]+ \]) (-?)[\£]([0-9]+\.[0-9][0-9]?)?"
Local $sString = "John Doe" & @CRLF & _
"+++++++++++++++++++++++++++++++++++++++++++" & @CRLF & _
"Blah blah" & @CRLF & _
"+++++++++++++++++++++++++++++++++++++++++++" & @CRLF & _
"[ √ ] £3.00 Red" & @CRLF & _
"[ √ ] £2.00 Blue" & @CRLF & _
"[ √ ] £55.55 Yellow" & @CRLF & _
"[ √ ] -£41.75 PAYMENT" & @CRLF & _
"[ √ ] £5.00 Green" & @CRLF & _
"[ √R ] £10.00 Pink" & @CRLF & _
"+++++++++++++++++++++++++++++++++++++++++++" & @CRLF & _
"Belugh" & @CRLF & _
"+++++++++++++++++++++++++++++++++++++++++++" & @CRLF & _
"Blah blah" & @CRLF & _
"Blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")