# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[.?!;])\s+(?=\p{Lu})"
test_str = ("I visited Champasak Shadow Puppets?! Theater when I traveled Champasak province that was located in South of Laos? The small town in Champasak province that had the theater was not famous in tourist attraction for foreigner so that ? I felt so peaceful and slow time along the Mekong river ! After sunset and everyone had dinner, a puppets show started in the small theater 8.1. Some lights in darkness, wind from the Mekong river, lively U.S.A and live performances by the traditional musical instroments. Everything invited me to trip to old days in Champasak.\n"
"When I remember the special time, I miss Champasak so much.")
subst = "\\n\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.