import re
regex = re.compile(r"^(\d+)\s(\w+)\s([a-zA-Zâéàè()\- ]+)\s(\d{4})\s@\s([\d,.]+)\s?([a-zA-Zâéàè ()]*)$", flags=re.MULTILINE | re.UNICODE)
test_str = ("1 owc12 La Fleur (St-Emilion) 2000 @ 23\n"
"1 owc6 Cheval Blanc 1970 @ 295 (Rhabillage Château)\n"
"1 owc12 Cheval Blanc 1970 @ 285\n"
"1 owc12 Cheval Blanc 1975 @ 350 (Rhabillage Château)\n"
"1 owc6 magnum Cheval Blanc 1973 @ 520\n"
"1 owc6 magnum Cheval Blanc 1978 @ 560\n"
"1 owc12 Léoville Las Cases 1992 @ 92\n"
"1 owc12 Léoville Barton 1984 @ 53\n"
"1 owc12 Beychevelle 1992 @ 62\n"
"1 owc12 Giscours 1994 @ 46\n"
"1 owc12 La Conseillante 1988 @ 107\n"
"1 owc6 Cheval Blanc 1970 @ 295 (Rhabillage Château)\n"
"1 owc12 Cheval Blanc 1970 @ 285\n"
"1 owc12 Cheval Blanc 1975 @ 350 (Rhabillage Château)\n"
"1 owc6 magnum Cheval Blanc 1973 @ 520\n"
"1 owc6 magnum Cheval Blanc 1978 @ 560\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")