re = /^(?:(?:(.+?) : (.+))|(?:(.+?) : )|(?: : (.+))|(.+))$/m
str = 'Cooper Koch : Erik Menéndez
Nicholas Alexander Chavez :
Nathan Lane
: Dominick Dunne
...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end