$re = '/^([a-zA-Z])\1+$/m';
$str = 'aa
aa.ahab
aaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);