package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d\|\||[()!]|&&|[^()!|&]+|\W`)
var str = `43 dogs & 16 cats&&(3 frogs||happy 2 foot toads)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}