const regex = /"(?=-?\d*\.?\d+E[+-]?\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(?=-?\\d*\\.?\\d+E[+-]?\\d+)', 'g')
const str = `"23452345235E9", "0342953475409E9", 324598732450843, "fooo", "2034598324509E9", 12342340985, "baaar", 234098549034E9, 453409340923`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}