re = /(< *br)[ \/]*>/m
str = '/* Linebreaks */
<br>
<br />
<br/>
/* Terrible linebreaks, but technically possible */
< br />
< br>
< br/>
< br>
<br />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end