$re = '/x{3}k|x{3}rb|x{3}\.x{4}|\d+/';
$str = 'xxxk
xxxrb
xxx.xxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);