$re = '/^.{4,56}$/m';
$str = '123456789012345678901234567890123456789012345678901234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);