using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<prod>\w+)-(?P<maj>\d).(?P<min>\d).(?P<bug>\d)(?:-(?P<pre>alpha|beta|rc)(?:\.(?P<pre_n>\d))?(?:\.(?:(?!centos|redhat)\w)+)?)?(?:\.(?P<os>centos|redhat))?(?:\.(?P<plat>snb|ivb))?$";
string input = @"foo-1.2.3
foo-2.3.4-alpha
foo-3.4.5-rc.2
foo-4.5.6-rc.2.extra
withos-5.6.7.centos
osandextra-7.8.9-rc.foo.redhat
os_and_plat-4.4.4-rc.1.foo.centos.ivb
issue-0.1.0-beta.redhat.snb
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}