import re
regex = re.compile(r"^[A-Z]+(-\d+)?", flags=re.MULTILINE)
test_str = ("OIDC-2843 Resource URL by domain in OIDC conf.doc.\n"
"BAPP-1234 Lorem Ipsum Tra La La\n"
"NOJIRA Updated deploy docs standard (edited) ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")