$re = '/\([a-zA-Z]{3}\) ([a-zA-Z]{3}-[a-zA-Z]{3})/';
$str = '(ABC) ABC-ABC
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);