import re
regex = re.compile(r"(\d+)\s*fps", flags=re.MULTILINE | re.IGNORECASE)
test_str = (" Stream #0:0[0x7d1]: Video: h264 (Constrained Baseline) ([27][0][0][0] / 0x001B), yuv420p(progressive), 1920x1080, 30 fps, 30 tbr, 90k tbn, 60 tbc\n"
" Stream #0:1[0x7d2]: Audio: mp3 ([4][0][0][0] / 0x0004), 0 channels\n\n"
" Stream #0:0: Video: h264 (High), yuv420p(progressive), 1280x720 [SAR 1:1 DAR 16:9], 30 fps, 30 tbr, 1k tbn, 60 tbc\n"
" Stream #0:1: Audio: aac (LC), 44100 Hz, stereo, fltp, 128 kb/s\n"
"Output #0, mpegts, to '/dev/null':\n\n"
" Stream #0:0: Video: h264 (High), yuv420p(progressive), 1280x720 [SAR 1:1 DAR 16:9], q=2-31, 30 fps, 30 tbr, 90k tbn, 1k tbc\n"
" Stream #0:1: Audio: aac (LC), 44100 Hz, stereo, fltp, 128 kb/s\n"
"Stream mapping:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")