#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^|[+-]?\d+\.\d*)$"
Local $sString = "TICKER|LAST_UPDE|PX_LAST" & @CRLF & _
"EE0002M Index|20211231|-0.58814" & @CRLF & _
"US0002M Index||" & @CRLF & _
"USB3MAY Index|20220502|0.8x9" & @CRLF & _
"SOFRRATE Index|20220505|c0.79" & @CRLF & _
"FEDL01 Index|20220505|0.83" & @CRLF & _
"US0001M Index|2022050|0.84486" & @CRLF & _
"FDTR Index|20220505|1" & @CRLF & _
"US0003M Index|20220505|1.37071" & @CRLF & _
"PRIME Index|20220505|4" & @CRLF & _
"TICKER|LAST_UPDATE|PX_LAST" & @CRLF & _
"EE0002M Index|20211231|-0.58814" & @CRLF & _
"US0002M Index|20211231|0.1525" & @CRLF & _
"USB3MAY Index|20220502|0.89" & @CRLF & _
"PRIME Index|20220503|3.5" & @CRLF & _
"SOFRRATE Index|20220504|0.3" & @CRLF & _
"FEDL01 Index|20220504|0.33" & @CRLF & _
"US0001M Index|20220504|0.84514" & @CRLF & _
"FDTR Index|20220504|0.5" & @CRLF & _
"US0003M Index|20220504|1.40614" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")