$re = '~^\D*\d+(?!/)(?=\D|$)~m';
$str = '12345This_is_awesome-2014.html
-12345This_is_awesome-2014.html
12345/This_is_awesome-2014.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);