import Foundation
let pattern = #"^(.+?)[-. ]{0,3}s?(\d?\d)[ex](\d\d)[-. ]{0,3}(.*?)[-. ]?(?:(?=pulcione|eng|ita|\w+Mux|\w+dl|\d+p|XviD|NovaRip).+)?\.([\w]{2,3})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
The.Big.Bang.Theory.S07E01.L.Insufficienza.Da.Hofstadter.ITA.ENG.720p.DLMux.h264-GiuseppeTnT.avi
Bobs.Burgers.3x17.ITA.ENG.ErVaas92[TnT.Village].mkv
American Dad! - 8x03 - Tutore terrore.avi
Supernatural.2x09.Croatoan.ITA.DVDMux.XviD-NovaRip.avi
Futurama 07x03 Verdetto 3012 480p WEBDL x264 mSD EiZO.mkv
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)