package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:UUID=)(?P<UUID>(.*?))>|(?:Make=)(?P<Make>(.*?))>|(?:Model=)(?P<Model>(.*?))>|(?:SDKClass=)(?P<SDKClass>(.*?))>`)
var str = `AMXB<-SDKClass=VideoProjector><-UUID=B8AC6FDFE1E2><-Make=DELL><-Model=S300w><-Revision=0.2.0>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}