$re = '/^\[INFO\].*/m';
$str = '[INFO] some info
no info
\'\' sup
another line [INFO]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);