$re = '/^(?:[\-\.\/\s]*[\d↉½⅓⅔¼¾⅕⅖⅗⅘⅙⅚⅐⅛⅜⅝⅞⅑⅒⅟])+/m';
$str = '1.5 5 tablespoon cram
½ (1 cup heavy cream
¼ – ½ teaspoon cream
1 tablespoon cream';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);