re = /^.+[^\/]$/m
str = 'apple/banana
apple/banana/
apple/banana /
apple/banana /
apple/banana/mango
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end