re = /(?:I\d-?)*I3(?:-?I\d)*/
str = 'A-B-C-I1-I2-D-E-F-I1-I3-D-D-D-D-I1-I1-I3-I1-I1-I3-I4-L-K-I3-P-F-I4-I2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end