$re = '/(?:(?<=\bPeach\b|\G) ).*?\b(\w{3,})\b(?=.*?\bApple\b)/';
$str = 'Peach, a nice family of fruits. Apple are not.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);