$re = '/("[^...]*?")(?=\s*\.\.\.|$)/';
$str = '"a string" ... \\\\"another \\"string\\"\\\\" ... "yet another \\"string" ... "failed string\\"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;