$re = '/([^:]*:\/\/)?([^\/]*\.)*([^\/\.]+\.[^\/]+)(\/[^\/]+)*/';
$str = 'http://www.google.co.uk.ss/nvklcs/jjvbigfd/bgyte';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);