using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"convert\([^,]+,(?!convert)([^,]+)";
string input = @"convert(nvarchar(10),convert(datetime,VARIABLE02 , 121), 103)
convert(datetime,VARIABLE02 , 121) convert(datetime,VARIABLE02 , 121)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}