use strict;
my $str = ' Hi there.';
my $regex = qr/^|\W/p;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";