$re = '~txt = Regex.Replace(txt, "¿", "?");~im';
$str = '12-3
3-12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);