re = /(?<=Name:).+?(?= *\|)/m
str = '..."|Keypad:6 |Name:Avacado Helmets |Pressed:E |Seconds:15.73 |Question Points:0 |Total:5802"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end