package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z]{3}:.*?[^\S]`)
var str = `ecl:gry pid:860033327 eyr:2020 hcl:#fffffd
byr:1937 iyr:2017 cid:147 hgt:183cm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}