re = /([+-]?)\s*(?:(?:(?:[^.([{]?(\d+))|(\d+\.\d+(?!\w+)))(?!\w+|\.))(?![([{])/
str = '2 + 2.2b - 2 + b + 2.2(2 - 2) + 2(- 2 - 2.2 + 2)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end